Nu stiu daca ati observat dar iframe-urile au revenit la putere de ceva timp. De fapt Facebook, Youtube si multe alte site-uri au inceput sa foloseasca iframe-urile. Am fost foarte nervos atunci cand am  vazut ca videoclipurile cu iframe dispareau din articole. Aceasta se intampla deoarece WordPress nu permite acest tag in editorul sau. Ce poti face?

Daca doresti sa permiti iframe-urile si alte taguri poti sa introduci urmatorul cod in  fisierul functions.php din directorul unde se afla tema ta.

function fb_change_mce_options($initArray) {
	$ext = 'pre[id|name|class|style],iframe[align|longdesc| name|width|height|frameborder|scrolling|marginheight| marginwidth|src]';

	if ( isset( $initArray['extended_valid_elements'] ) ) {
		$initArray['extended_valid_elements'] .= ',' . $ext;
	} else {
		$initArray['extended_valid_elements'] = $ext;
	}

	return $initArray;
}
add_filter('tiny_mce_before_init', 'fb_change_mce_options');

Citeste si:   Wordpress 3.5

Spune si tu parerea...